iMac und aktive Audiomonitore: Brummen, Fiepen

Hintergrund
Die letzten Tage beschäftigte ich mich mit folgenden Ausdrücken: ground loop, ground noise, ground lift und ground hum. Verwendet man diese Suchbegriffe beispielsweise in google und fügt ihnen “iMac“, “Apple” und “active Monitor” dazu, so bekommt man eine ansehnliche Zusammenstellung von Treffern. Natürlich darf man die Begriffe auch in Deutsch verwenden (Masseschleife, Brummschleife, Erdschleife, usw.). Und auch diese Eingabe offenbart eine umfangreiche Suchtreffer-Liste vieler leidgeprüfter Apple-Benutzer. Diese Anwender haben alle ihre Macs mit aktiven Abhörmontitoren ausgerüstet… Ich bin einer davon.

Verwendung (aktiver) Abhörmonitor
Abhörmonitore unterscheiden sich von normalen HiFi-Musikboxen dadurch, dass sie das Audiomaterial vom Frequenzspektrum her möglichst neutral wiedergeben. Sie verfügen zudem über einen breiten Abstrahlwinkel und können hohe Pegelspitzen verzerrungsfrei wiedergeben. Zudem sind Audiomonitore magnetisch abgeschirmt, damit störende Einflüsse verhindert werden.
Es wird unterschieden zwischen aktiven und passiven Monitoren. Aktive Geräte verfügen über einen eigenen, eingebauten Leistungsverstärker und eine eigene Stromversorgung. Die passive Variante benötigt einen Leistungsverstärker. Heutzutage werden im Studiobereich hauptsächlich aktive Monitore verwendet, da sie über eine aktive Frequenzweiche, einen Limiter- und/oder Dynamikprozessorschalter verfügen.

iMac und aktive Abhörmonitore: Fiepen, Rauschen, Brummen
Als ich meinen Mac mit den neuen aktiven Monitoren ausrüstete, war die Freude mit dem Anschalten der Geräte vorbei. Links und rechts rauschte und fiebte es gewaltig. Irgendetwas störte da gewaltig. Selbst Seitenscrollbewegungen mit der Maus konnten plötzlich akustisch verfolgt werden. Festplattenzugriffe liessen sich über die neuen Boxen durch ein Brummen und Knattern vernehmen. Dass meine gekauften Monitore auch feinste Nuancen wiedergeben sollen, habe ich mir erhofft. Dies hier ging mir aber doch zu weit…

Ursachenforschung
Natürlich ging ich sofort davon aus, dass ein einzelnes Gerät oder Kabel für die Störungen verantwortlich sein musste. Also setzte ich auf ein Ausschlussverfahren:

  • Alle USB-Geräte weg – kein Erfolg
  • Alle Firewire-Geräte weg – kein Erfolg
  • Alle Lichtquellen ausschalten und ausstecken – kein Erfolg
  • Alle restlichen Peripheriegeräte komplett ausstecken – kein Erfolg
  • Alle übrigen Stromverbraucher im Haus ausstecken, Ausnahme iMac und Audiomonitore – kein Erfolg
  • Verzicht auf die Backup USV (Unterbrechungsfreie Stromversorgung) in diversen Kombinationen – kein Erfolg
  • Ersetzen sämtlicher Stromschienen – kein Erfolg
  • Ausschalten sämtlicher Bluetooth und W-LAN Geräten – kein Erfolg
  • Bildschirmhelligkeit des iMac auf 100% stellen – kein Erfolg
  • Ausschalten des DECT-Telefons – kein Erfolg

Natürlich installierte ich den iMac und die Boxen in einem anderen Raum. Doch auch hier war das Fiepen und Summen überdeutlich wahrzunehmen… Langsam ahne ich, wo das Problem liegen musste: Die neu erworbenen Boxen waren einfach Schrott oder der iMac kaputt…
Um dieses Problem zu lösen, griff ich auf mein Sammelsurium alternativer Geräte (andere Computer und Abspielgeräte) zurück und schloss diese an meine neu erstandenen Behringer Audiomonitore an. Das Resultat: Die Audioboxen lieferten einen kristallklaren Sound ohne die unerwünschten Symptome – Nur eben beim iMac wollte es nicht klappen.

Der Sündenbock: iMac 27″

USB-Soundkarte leitet die Störgeräusche weiter...
USB-Soundkarte leitet die Störgeräusche weiter...

Da das Problem nun eingegrenzt werden konnte, ging es mir nun darum herauszufinden, was das Problem beim iMac überhaupt war.
Ich hatte mir einen iMac 27″ (2009, 2.8 GHz Core i7) eingefangen, der wegen eines minderwertigen Netzteils eine sogenannte Brummschleife erzeugt. Diese Vermutung wurde mir durch umfangreiche Nachforschungen im Netz zu den Suchbegriffen, welche ich im ersten Kapitel angegeben habe, bestätigt.
Die Symptome sind am schlimmsten, wenn ich die Boxen direkt an den LINE-OUT-Anschluss des iMacs hängte. Interessanterweise waren diese störenden Geräusche auch dann deutlich wahrnehmbar, wenn ich eine externe Soundkarte (bei mir eine Native Instruments Komplete Audio 6) über USB verwendete. Auch halfen verschiedenste Kabel und Steckerversionen (XLR, TRS, RCA) und -Kombinationen nicht oder nur sehr wenig… Nutzer welche Soundkarten über Firewire verwendeten, so konnte ich nachlesen, konnten keinen Erfolg verzeichnen – Ausser sie verwendeten Adapterstecker von Firewire 800 -> 400.
Interessant, dass mein iMac bisher diese Symptome bei anderen Audio-Ausgabegeräten nie zeigte, weder bei Kopfhörern (darunter auch aktive), noch bei herkömmlichen 2.1-Audio-Systemen (Logitech, Harman Kardon, JBL). Das war wohl nur Zufall. Diese Geräte verfügten alle über einen 2-poligen Eurostecker (Wikipedia-Link)…

Die Brummschleife
Das Problem wurde erst durch die aktiven Monitore verursacht, weil diese wie der iMac über ein Gerätekabel des Stecker-Typ J (Wikipedia-Link) verfügen. Der so geerdete iMac und die ebenso geerdeten Audiomonitor verursachten diese Brummschleife. Diese entsteht allgemein, wenn es zu einer zweifachen, direkten Verbindung der Massenpotentiale kommt, verursacht durch eine doppelte Erdung via Schutzleiter der beteiligten Geräte. Ich habe dann auch probiert, den iMac von einem anderen Zimmer (Stromkreis) mit Energie zu versorgen. Dies zeigte keinen Effekt. Das liegt wohl auch daran, weil wir in einem älteren Haus wohnen.

Die Lösung aller Probleme - Für Lebensmüde
Die Lösung aller Probleme - für Lebensmüde

Lösung für Lebensmüde
Was ich dann auch probierte, um die Ursache klar bestätigen zu können war, dass ich den Erdungspool, also den Schutzleiter beim Stecker-Typ J des iMac mit Klebeband abisolierte… Bitte liebe Kinder, macht das zu Hause nicht nach! Auf jeden Fall war dann Ruhe, absolute Ruhe… und damit auch die Ursache des Problems bestätigt. Damit aber nicht behoben!

Di Box: Endlich Ruhe!
Di Box: Endlich Ruhe!

Praktikable Lösung
Das Problem lag nun offen auf dem Tisch und konnte somit gelöst werden. Weitere Nachforschungen im Netz sprachen von einer sogenannten DI Box (Wikipedia-Link). Diese Boxen helfen unter anderem auch dabei, die Masseverbindung aufzutrennen (Ground Lift) und damit das Brummschleifen zu unterbrechen.
Ich entschied mich für ein Produkt von Behringer – Das HD400. Das passive Kästchen wurde einfach zwischen Soundkarte (Bei mir das Native Instruments Komplete Audio 6) und den Behringer Boxen installiert. Nun habe ich endlich den Sound, den ich mir mit der Anschaffung aktiver Studiomonitore erhofft habe. Kein Brummen, Fiepen und Rauschen mehr, dafür einen kristallklaren Sound.

Kleiner Seitenhieb am Rande
Wäre bei meinem iMac nicht ein solch minderwertiges Netzteil verbaut worden, wäre diese Probleme gar nicht erst aufgetreten. Liest man Forenmeldungen zu diesem Brummschleifenproblem, wird klar, dass durch dieses Phänomen viel Ärger auf Seiten der Anwender verursacht wurden. Durch das Verbauen eines höherwertigeren Netzteils wären die iMacs wohl 2$ teurer, dafür immun gegenüber dem ground loop… und ich hätte nicht knapp 100 Franken mehr für eine Di Box und die zusätzlich benötigten Kabel investieren müssen.

Time Capsule auf 2 TB aufrüsten

Heute habe ich meine Apple Time Capsule mit einer 2 Terabyte Festplatte aufgerüstet. Der Umbau war erstaunlich einfach.

[nggallery id=18]

Aber die neu verbaute Western Digital Caviar Green (WD20EARS) ist im Vergleich der alten 500GB-HD nicht nur grösser, leiser, sondern entwickelt spürbar weniger Wärme – toll! In Zukunft werden alle drei bestehenden Laptops mit der Time Capsule über Time Machine gesichert. Natürlich habe ich nicht einfach den Schrauberzieher genommen, sondern mich insbesondere an die Anleitung auf der Webseite http://www.applefritter.com/node/23907 gehalten.

Wacom Intuos4 und Snowleopard (10.6)

Zwar wird Leopard bereits seit Tagen mit einem kleinen Update betrieben (10.6.1), doch einige Kleinigkeiten stören noch immer im täglichen Betrieb.
Wacom Grafiktablet funktioniert bei mir leider nur bedingt. Nach einem Neustart kann es schon vorkommen, dass das USB-Gerät entweder nicht erkannt wird oder die von mir gemachten Benutzereinstellungen gehen einfach verloren. Ob dies an den 32-Bit-Treibern der Firma liegt, kann ich nicht beurteilen. Wacom selbst schreibt im firmeneigenen Forum, dass sie das Problem erkannt hätten und an einer Lösung arbeiten würden. Ein 64-Bit Treiber ist in Arbeit. Apples 10.6.2 steht auch in den Startlöchern. Trotzdem möchte ich ja heute arbeiten und nicht erst morgen.

wacom32bit

Hier also eine vorläufige Lösung, wenn Einstellungen wieder verloren gehen: Werden in der Systemeinstellungen die Wacom-Einstellungen geändert, muss die Systemeinstellung geschlossen werden. Anschliessend wird die Systemeinstellung wieder geöffnet und auch die Wacom-Einstellung angeklickt. Erst jetzt werden die Benutzeränderungen von vorhin gespeichert.
Wer dem Ganzen noch immer nicht traut, kann die Wacom-Einstellungsdatei auch separat speichern. Es handelt sich dabei um die Datei ‘com.wacom.wacomtablet.prefs’, welche sich im Ordner ‘user/library/preferences’ befindet. Mit TimeMachine geht die Wiederherstellung einfach, da einfach auf eine ältere Datei zurückgegriffen werden kann. Wer parallel mit 10.5.x arbeitet, kann sogar von diesem System die Einstellungsdatei nehmen.

Update 1:
Bei Wacom USA gibt es einen neueren Treiber (6.1.2-3) zum Download. Dieser Treiber ist 64-Bit. Ich teste nun das Ganze.

Update 2:
Auch der neuste Treiber (6.1.2-5) führt nach ein paar Tagen zu massiven Speicherüberläufen, was zu einem zähen System führt. Der Mac ist dann praktisch nicht mehr bedienbar. Hier hilft es, mit dem Wacom Deinstallationsprogramm die Treiber zu entfernen. Nach einem Neustart wird das ganze wieder installiert, worauf der Mac wieder normal benutzt werden kann. Danke Sinan für die Bestätigung, dass das Problem nicht nur bei mir liegt!

Der Schneeleopard: Erste Eindrücke

blog_BE291087

Seit ein paar Stunden läuft der Schneeleopard (Mac OS X 10.6) auf einem Testsystem. Die Installation ging ohne Schwierigkeiten vonstatten. Erste Schwierigkeiten machten sich aber bald nach dem Start bemerkbar. So bemängelt das System, dass der Treiber für meinen Canon Scanner (Lide500F) nicht kompatibel sei. Auch mein “uralt” Scanner läuft nun wieder. Mit dem Programm “Digitale Bilder” kann der Scanner angesprochen und betrieben werden!
Schlimmer noch die Meldung, dass mein UMTS-Modem (Huawei E220 mit Launch2Net) nicht unterstützt wird, da keine Treiber verfügbar sind. Wenigstens muss ich so nicht mehr im Zug arbeiten… Nach einer Deinstallation und Neuinstallation mit Aktivierung wird Launch2Net nun unterstützt. Super!

Systemeinstellungen
Auffallend, dass einige Systemeinstellungsapplikationen von Drittherstellern nicht direkt gestartet werden können. Die App “Systemeinstellungen” wird beim Bestätigen nochmals im 32Bit-Modus gestarten (Siehe Bild unten). Dies betrifft bei mir Wacom Intuos4, Flip4Mac, Foxmarks, MacFuse und SmartSleep… Ich dachte, dass 10.6 von Haus aus erstmal nur mit 32Bit betrieben wird… Da muss ich mal nachforschen. Bildschirmfoto2009-08-29um151626

Eine gute Erneuerung in den Systemeinstellungen ist, dass sich nun der Trackpad wesentlich vielfältiger konfigurieren lässt. Funktionen wie “Vergrössern”, “Drehen” lassen sich deaktivieren. Darüber bin ich froh.

Anwendungen
Ansonsten gehen bei mir alle wichtigen Anwendungen, angefangen mit: MS Office 2008, VPN Tracker, Photoshop CS3, Coda, Garmin BaseMap, Parallels Desktop 4, Truecrypt und natürlich alle Apple eigenen Programme wie Aperture, Remote Desktop, Logic und die iLife-Sammlung. Gröbere Abstürze habe ich noch nicht provozieren können.

Fazit
Aber ehrlich: Ich hätte nicht gemerkt, dass nun Leopard Snow läuft. Neue Feature sind sehr gut versteckt und machen sich erst bei näherem Hinsehen bemerkbar. Überraschend durfte ich jedoch feststellen, dass meine Festplatte um mehr als 15GB Platz gewonnen hat!
Fürs Erste ist Mac OS X Snow Leopard (10.6) einfach ein umfangreiches, kostenplichtiges Update.