Es ist heute normal geworden, dass viele Geräte ein eigenes Betriebssystem und/oder eine Firmware mit sich bringen. Diese zentrale Software lässt sich von Zeit zu Zeit aktualisieren. Man kennt dies von Mobiltelefonen, Computern, Autos und teilweise sogar Nähmaschinen. Mit diesen Softwareupdates werden neue Funktionen freigeschaltet oder Fehler ausgemerzt. In manchen Fällen jedoch bringt ein Update keine erhofften Verbesserungen, sondern im schlimmsten Fall kann das Gerät nicht mehr richtig in Betrieb genommen werden.

Dieser Umstand scheint bei meiner NAS QNAP TS-210 mit der neusten Firmware 3.3.3 (Build 0928T) leider genau eingetroffen zu sein. Ständig verliert die Diskstation die Netzwerkverbindung und kann somit nicht mehr kontaktiert, geschweige den genutzt werden. Die Fehlermeldung ist gewohnt nichtssagend kurz: “Level:  Error – Network connection lost”.

Was hilft ist ein Reset (Miniknopf am Gerät lange gedrückt halten). Auf die Station lässt sich dann wieder zugreifen, jedoch muss die Netzwerkkonfiguration wieder eingestellt werden. Die NAS holt sich nach dem erfolgten Reset einfach die nächstbeste IP-Adresse aus dem internen Netz. Das Problem der Firmware 3.3.3. scheint also genau in der Netzwerkfunktion der NAS zu liegen. Sobald man die NAS nach dem Reset wieder so konfiguriert, dass man ihr eine fixe IP-Adresse reservieren möchte, kommen die Verbindungsabbrüche.

Probleme tritt dann auf

Es gibt aber zwei Lösungen, wie man trotzdem bei der fixen IP-Adresszuteilung bleiben kann.
Das Problem taucht nur auf, wenn beim Aufstarten der NAS eine externe USB-Festplatte am USB-Port hängt und im Adminmenü der NAS eine fixe IP-Adresse zugeteilt worden ist. Nach einem erfolgten Aufstart kann jedoch eine USB-Platte angehängt werden und die Netzabbrüche kommen nicht vor… Ist sehr unpraktisch, wenn die NAS automatisch nachts runterfährt und morgens wieder hochfährt…

Wer jedoch auch einen Router hat mit dem sich einem Gerät eine IP-Adresse zuteilen lässt, soll dies so machen. Das NAS-Gerät kann bei der IP-Einstellung automatisch die IP beziehen, bekommt aber die vom Router zugeteilte fixe IP. Somit tritt das Problem auch nicht auf.

Da mein Router diese Funktion nicht mit sich bringt, hat meine NAS nun 2 TB weniger Speicher. Ich hoffe, QNAP wird, wie versprochen, bald einen Fix herausbringen. So wird das auf Dauer nichts…